Trimble ID server - Not working

Is anyone else having issues logging back in to their Trimble ID account. RPS had me log out and now I can no longer get logged back in. I am running the latest version of TBC with the latest patch. I miss my RPS tools so hopefully this can be resolved quickly. ~Thomas

Yes I have had that issue today, the only solution I found was closing and restarting TBC. Then everything worked again.

But yes really strange that you (and I) couldn’t log on, I’ve even tried deleting my external profiles in the options and tried to complete a new profile but the log on credentials didn’t even pop up so no way to log on.

I saw an issue yesterday with one user that upgraded to 5.60 and then applied the Patch update ton 5.61 and after doing those things he could not get out to the Trimble ID page from within TBC. I had them deinsall TBC and then download the Offline Installer for 5.61 and install that and on completion everything worked fine again.

If you see an intermittent issue you can log out in Support Options and then Login again and that normally clears it. We have reported an issue with Trimble ID apparently going to sleep and losing its connection / login - they did do some work in 5.6.1 to address that - I cannot say yet whether it fixed it or not - early days yet.

We are working on an updated license that will coast for up to 24 hours in the event you lose Internet Connection and also a license that you can check out for up to 30 days that will allow you to go offline with the RPS tools for up to 30 days. These will be less dependent on Trimble ID and provide a lot of increased operational flexibility for those that need it.

Hopefully you will see those changes in January


Hi Guys,

What about Trimble Sync Manager too - its not uploading Data files to certain Projects

  • and now my Trimble ID is also not working (5.60.1)

When you say it is not working - have you checked support - options - external services - profiles and set up Trimble ID and them sign in

Does it get you to the sign in page in browser?

If you sign in does it fail to sign you in?

Check your username and password and reset if necessary

Where is it failing ?

I am using 5.60.1 and it is working for me OK

I did a full 5.6 1 install rather than update 5.60 and I always use the off line installer to do that.

Not saying that the online installer or patch is failing just saying how I installed successfully here and maybe you need to do that also to get a working system - the other methods may be fine but I have hit issues with 2 other users this week and doing what I did cured the issue



I am encountering the same issue. I can’t login with my Trimble ID. I will try the options you are saying Alan. (Edited when i try to sign in it just spins the wheel for a second and then nothing) Same result on start page and under support options. No sign in page in browser.


This is what I was seeing the other day - deinstall TBC, download the 5.61 offline installer and install from that - it worked the other day - hope that it will work for you also




I did exactly what you suggested and I am up and running again with no more issues with the TID.
Thank you much!

1 Like

Deinstalled and used offline installer. Problem solved. Thanks Alan!!!