Trimble.ExternalService.Daemon failed to start error resolution

We now have a solution from Trimble on the error that several of you have been getting when trying to install TBC V5.9.

“Error 1920. Service Trimble External Service Daemon
(Trimble.ExternalService.Daemon) failed to start."
during the installation of Trimble Business Center

Problem:

The Trimble Business Center (TBC) installation may fail with the error:

“Error 1920. Service Trimble External Service Daemon (Trimble.ExternalService.Daemon) failed to start.
Verify that you have sufficient privileges to start system services.”.

Cause:

The Webroot antivirus software detected the file installed under
“C:\Program Files\Trimble\ExternalServiceDaemon\Trimble.ExternalService.Daemon.exe”
as a malicious threat and quarantined it.

Resolution:

Webroot have confirmed that this detection was a false positive and have whitelisted the file.

To prevent Webroot from re-detecting the file:

 1. Sign into the Webroot console at https://my.webrootanywhere.com/default.aspx.

 2. On the left side menu, select the "Manage" drop down to expand the options and then click the
     "Entities" option.

 3. In the main display, locate the site and expand it using the arrow on the left, then click the
     check mark option to the left of the affected host.

To restore the file(s):

 1. At the top of the screen click the 'Agent Commands' drop down list and select 'Restore File'
     from the commands list.

 2. Add the MD5 file hash below, then click Restore File.

     MD5: 46c148910ef75b01354e409da5684c75

     This will restore all files matching the specified MD5 from quarantine to their original locations.
     If an error is received while restoring the file, try reinstalling the software again.
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