Layer Not Visible in Graphic View

I am having an issue where I created a new layer and when I try to draw a polyline, the new layer gets the not visible warning. I tried drawing a line using a layer that is visible in plan view, but that layer also has the yellow warning bubble. It seems that all of the layers visible in plan view are not visible when picking which layer to draw the polyline in. The boxes are checked in the view filter and I have it set to my filter and everything for the selection sets. My Does anyone know about this issue?

Can you share the Project and let me know which layer you are having issues with. I have just looked at all the things that I think you could have done and I don’t see a way that you can create a layer, have it listed in the Project Explorer as visible and then get that warning - I may find the reason if I can look at your project. Have you tried creating eg a New Plan View and try changing the View Filter to All - is the layer then visible?

If you are still having issues on Monday we can try a GoTo Meeting to see if I can see what you have done to create the situation.

If you save the project, close it and reopen it do you get the same problem. If you close TBC and restart do you get the same problem?

Sounds like an interesting issue - what version are you running?

Project IRIS REV 3-12-19.vce (48.1 MB)


Here is my file. Hopefully this is the one that I was unable to make work. Before I sent this I opened a new plan view and it still would not have the layer visible. I then went messing around in the Selection Sets and found a set for unassigned objects and checked and unchecked the available boxes and now it is working. I am sending this .vce to you to see if it will replicate the issue since I have not saved it since I got it working and maybe you can find something that I might have done. I am running V5.40. Thanks for your help.

Sorry I forgot, the layer is S1 Edge.

I went into the Selection Sets in the View Filter Manager and turned One on and then off again and it cleared - so I guess it lost itself somewhere - you probably managed to create conflicting scenario somehow - one thing said show and the other said hide and when you switched those off somehow it did not clean properly - I don’t know how you could have done that, but software is software - it can get into those types of state sometimes.

I can recreate it and can send it in for Trimble review - so thanks - it clears as soon as you turn On / Off a Selection Set - weird - good catch!