Importing 12d files - Surface disappears when recalculating surface

I’ve recently imported a 12d file

It brings in the following information on import

  1. all alignment file
  2. Finished Surface
  3. Bulk Excavation Surface

I have noticed if you change the triangle maximum edge length in the property pane, that it loses all the surface triangle, and the surface is unable to recalculate.

Making the edge length shorter or longer? If too short the triangles will fail to form.

If you need me to take a look send me the file and the edge length you want to use and I will take a look for you and I can let you know what I see.


Hi Alan

I’ve sent you a link via trimble connect…I think it a problem with the 12d file

I just tried exploding the surface, which worked to create a layer for the triangles

But then tried to run project clean up on the line-work / triangle and it take forever (over 8 hours and still going)

Thinking the best option is going to be

  1. Explode Surface - Relayer
  2. Create New Surface
  3. Export TTM file
  4. Delete - Re-layer Surface layer
  5. Re Import TTM & Re Explode to triangle can be cleaned up

You should not need to run cleanup on the triangles created by Explode surface because we only write one line per triangle side so you should not have any duplicates - if you had duplicates let me know as that would be a defect in the explode surface command


I looked into this and see what you are seeing - the issue is caused by the way that the surface is being created on import. That importer is managed by the SITECH / Ultimate Positioning guys out of Australia and there is not much I can do - I found that if I recreated the surface from the strings - the TBC surface was fine - and did not do the same thing - if you look at the 12D surface it has some weird null property and I am not sure what that means - would need to talk to the Aussie guys on that.

If you look at the properties of the surface and set the color of the surface to a custom color with RGB values 100,101,102 you can see all of the triangles that have been nulled out (this color specifically will show all the hidden triangles of a surface e.g. those nulled out using a Null texture or those nulled out using surface boundaries - in this case the there are evidently some Null Triangles in the 12D surface once it has been created by import - so the 12D surface has some nulling / hiding of triangles going on).

Because the boundary string is criss crossing the outermost strings, this is getting confused as to what is Null vs what is not Nulled and when you change the triangle side and force the surface to rebuild, the nulling is recomputed and that is wiping all the triangles and setting them all to be null - which is why you cannot see them.

The null locations are stored in the surface, and unless the Australian guys are dropping that as a null texture that you can edit or move / remove, you basically have to rebuild the surface from the strings in TBC to make a usable surface if you want to adjust the edge length.

Not much you can do other than build the surface from the Strings and ignore the surface created by the 12D importer.

Here is a pic of the 12D surface straight after import showing all the Triangles including the Nulls

Here is a picture not showing the Nulled Triangles of the 12D surface

Example of where the TIN Boundary and daylight line is not matching - in these areas somewhere there are very slight cross overs where the string daylight falls outside the boundary line which I guess is being used to null out the triangles on the outside of the boundary line - this makes the triangles that are attached to that node null and as a result the whole surface gets nulled when you force it to rebuild.

Red line is the daylight line, Blue line outside is the boundary string - if you trace these you will see that in some places they are the same and in others they separate - and i believe that if we could track this we would find the place(s) at which they cross over each other causing the issue you are seeing.
This is not uncommon with Design software products - their tolerances can be off a touch and that can trigger this issue - we are talking maybe less than 0.1mm error - that is enough to trip this behavior.


Thanks, Alan always helpful

  • That what I did for the finished surface,
  • The subgrade surface I exploded and relayed, then reprocessed the surface and that seemed to work.

What I was going to do is to recreate the corridor template along this alignment, as there are major problems with the surface tieing into the natural ground due to the accuracy lidar data.