DWG Data NOT Displaying

I am trying to work with a DWG file and the data is not displaying even with all layers turned on. I have tried dragging and dropping and using the Import Command. The only data that displays is a 3D rectangle around the site. The data and a tin model imported successfully. I’m not sure what is going on or if I am doing something wrong. Any help would be greatly appreciated.


Alan has several tips on CAD import if you search the community. Can you use the CAD Cleanup command to zoom in on blocks in the drawing (assuming there are blocks)? Does it help to turn the “All” view filter on?
If you upload the file we could open it and see if we are getting similar results…

Thanks for replying.
I think I figured it out. It has to do with AEC objects created in Civil 3D. As far as I know, I need to do 1 of 3 things. Either, open with Auto Desk and export as a Civil 3D Drawing (recommended by RPS), open with Auto Desk and export as a Land XML (recommended by SiTech), or address the non-compatible objects in AutoCAD and save. The only problem is that I currently do not have access to Auto Desk. I will search the forum for additional info as well.

Try Autodesk DWG TrueView

Will do.

Thanks for the help

I tried using TrueView, but it doesn’t output to LandXML or Civil 3D. My coworker who is an Auto Desk user was able to convert to Land XML. The problem lies in the AEC objects.

I should have been more specific. The DWG Convert tool in TrueView is a free way to do the same thing as “Export to AutoCAD” in Civil 3D and eliminate AECC objects to make things show up more nicely in TBC.


In Civil 3D, PROXYGRAPHICS needs to be set to 1. AEC objects will be visible in other cad programs when set to 1. O is default and unfortunately you need Civil 3D to change this.


1 Like

Download free trial civil 3d. Import dwg. Changegraphics command 0 to 1. Explode command…all…export.